BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      12-09-2018, 12:32 AM   #1
Ryder6foottoo
Ryder
United_States
2
Rep
5
Posts

Drives: 08 135i M-Sport
Join Date: Dec 2018
Location: Raleigh, NC

iTrader: (0)

135i is getting on my last nerve.

So I have had my 135i for about 2 years now and for the first year it was flawless.

Me being ridiculous I decided to go all out last year.
I went FBO+

Charge pipe
Catless downpipes
5" intercooler
DCI
MHD 2+ tune

PLUS
LWFW
Short Shifter
Stage 3 clutch
Quick release wheel
And other small things

SO HERES THE REAL PROBLEM

I was going down the highway and minding my own business. Decided to mess around and popped it up to about 6000rpm.

Well that apparently was a terrible idea. Car immediately went into limp mode and stayed there for days. Checked the code and it was for a lean bank 1 and multiple cylinder misfire.

I decided to take it to an unnamed shop.
They told me it was my ECU.

So I had it replaced. Problem was better. But not fixed.

So I took it back. They told me it was my index 09 injectors.

Okay then. Replaced with index 12.
Problem got worse.

They told me it was potentially a plug or wire issue.
Okay no problem I guess.

Replaced with Precision Moterwerks Coilpacks and new plugs.

Problem continued.

Took it back AGAIN for some reason.
THEY TOLD ME IT WAS MY ECU AGAIN.

For some reason I let them "recode my ECU"
THE PROBLEM GOT SO MUCH WORSE I AM GETTING ABOUT .3MPG RIGHT NOW.

Oh you read that right. I said . 0 3. NOT EVEN 1MPG

So I know for sure this means there's a stuck injector.

But this problem was never there before.


PLEASE SOMEONE PLEASE HELP ME FIGURE OUT WHATS WRONG WITH MY CAR.

I haven't properly driven it in almost a year. I am giving up and I don't want to. I don't know what else to do.

Someone please tell me there's someone with the intelligence to help me figure out what's going on.
__________________
?08 135i FBO
?04 330i Daily
?96 Z3 - Sold :?(
?86 725i - Sold
Appreciate 0
      12-09-2018, 12:33 AM   #2
Ryder6foottoo
Ryder
United_States
2
Rep
5
Posts

Drives: 08 135i M-Sport
Join Date: Dec 2018
Location: Raleigh, NC

iTrader: (0)

Also first post. Heh.
__________________
?08 135i FBO
?04 330i Daily
?96 Z3 - Sold :?(
?86 725i - Sold
Appreciate 0
      12-09-2018, 10:41 AM   #3
tracer bullet
Lieutenant Colonel
tracer bullet's Avatar
United_States
642
Rep
1,795
Posts

Drives: '11 135i , '15 X3 35i
Join Date: May 2011
Location: Saint Paul, MN

iTrader: (1)

Sounds like your shop choice is incompetent, unfortunately. Was it a random shop or one claiming to have BMW expertise?

Raleigh / Durham / etc. should be big enough, I'd think, to have a good shop - maybe keep looking around. Dealership in theory should know what they are doing too and might not actually be more expensive.
Appreciate 0
      12-09-2018, 10:53 AM   #4
gtjosh
Private First Class
17
Rep
119
Posts

Drives: Silver 2011 135i DCT
Join Date: Mar 2016
Location: New Braunfels, TX

iTrader: (1)

I have a friend that works at a shop near there. I have seen the work they do and I am sure they can fix it. The shop is sweedish performance and parts. I have seen many bmw's roll through that shop with complicated issues. This is the address 429 Industrial Dr, Wendell, NC 27591.
Appreciate 1
      12-09-2018, 11:37 AM   #5
Ryder6foottoo
Ryder
United_States
2
Rep
5
Posts

Drives: 08 135i M-Sport
Join Date: Dec 2018
Location: Raleigh, NC

iTrader: (0)

Quote:
Originally Posted by gtjosh View Post
I have a friend that works at a shop near there. I have seen the work they do and I am sure they can fix it. The shop is sweedish performance and parts. I have seen many bmw's roll through that shop with complicated issues. This is the address 429 Industrial Dr, Wendell, NC 27591.
Quote:
Originally Posted by gtjosh View Post
I have a friend that works at a shop near there. I have seen the work they do and I am sure they can fix it. The shop is sweedish performance and parts. I have seen many bmw's roll through that shop with complicated issues. This is the address 429 Industrial Dr, Wendell, NC 27591.

THANK YOU! The only BMW shop around me (which I won't mention their name because I'm sure they're on here.) has charged me around $600 in JUST diagnostics fees and they have done nothing but make my car worse.

I'll give them a call once the snow clears.

Thank you so much.

Anyone else that may have had this issue before that can give me some input to try I'd appreciate it.
__________________
?08 135i FBO
?04 330i Daily
?96 Z3 - Sold :?(
?86 725i - Sold
Appreciate 0
      12-10-2018, 03:37 PM   #6
PA135ii
seeking salvation
225
Rep
565
Posts

Drives: 08 135i 08 CR-V
Join Date: Jan 2018
Location: Pennsylvania

iTrader: (0)

Please let us know what the solution was and what they actually found.
I'm having continual issues with my '08 135i as well, and I feel your pain.
My indy shop has it now, in fact.
Hang in there.

p.s.- if you want to read my tales of woe... it's in the cam seal thread.

Last edited by PA135ii; 12-11-2018 at 11:35 AM..
Appreciate 0
      12-10-2018, 03:38 PM   #7
Ryder6foottoo
Ryder
United_States
2
Rep
5
Posts

Drives: 08 135i M-Sport
Join Date: Dec 2018
Location: Raleigh, NC

iTrader: (0)

Quote:
Originally Posted by PA135ii View Post
Please let us know what the solution was and what they actually found.
I'm having continual issues with my '08 135i as well, and I feel your pain.
Hang in there.
I will. It's snowing in NC so later this week I'll try to get it out to the shop.
__________________
?08 135i FBO
?04 330i Daily
?96 Z3 - Sold :?(
?86 725i - Sold
Appreciate 1
PA135ii224.50

      12-25-2018, 12:05 AM   #8
iminhell1
C2H5OH
iminhell1's Avatar
United_States
1101
Rep
1,460
Posts

Drives: 2010 SG 135i auto
Join Date: May 2015
Location: Darwin, MN

iTrader: (1)

Well, over summer I'd helped a kid at the track fix his N55. He was having random misfire codes, not repeatable, not RPM or load based.
I gave it a look over, wiggled on this and that and just happened to find an injector connector that was only partly pushed in.
Pushed it in all the way, clear code, car ran flawless.


#1 rule of diagnosis, double check previous work.


And i don't care if this 'shop' is on here or not. This sounds like they've been stealing your money. Ethically, you bring them a car and expect to receive a repaired and fully functioning one back. That has not been the case. I see no harm in naming them and warning others, or maybe we can hear their side of this.
__________________
FBO (RB EVO inlets, Phoenix Racing 7.5" race, CP-e relocate / Tial, 1320 DP's, Berk mids, Custom E tune, XHP Stg III)
11.480 @ 121, 3,600#
Appreciate 0
      12-25-2018, 12:32 AM   #9
Ryder6foottoo
Ryder
United_States
2
Rep
5
Posts

Drives: 08 135i M-Sport
Join Date: Dec 2018
Location: Raleigh, NC

iTrader: (0)

Quote:
Originally Posted by iminhell1 View Post
Well, over summer I'd helped a kid at the track fix his N55. He was having random misfire codes, not repeatable, not RPM or load based.
I gave it a look over, wiggled on this and that and just happened to find an injector connector that was only partly pushed in.
Pushed it in all the way, clear code, car ran flawless.


#1 rule of diagnosis, double check previous work.


And i don't care if this 'shop' is on here or not. This sounds like they've been stealing your money. Ethically, you bring them a car and expect to receive a repaired and fully functioning one back. That has not been the case. I see no harm in naming them and warning others, or maybe we can hear their side of this.
Well if they care to comment the shop is Called Bimmer Performance Center in Raleigh, NC. I've tried discussing the situation with them and they don't care to hear anything I've had to say, nor correct what they've wronged. They just ask for more money.
__________________
?08 135i FBO
?04 330i Daily
?96 Z3 - Sold :?(
?86 725i - Sold
Appreciate 0
      12-25-2018, 05:57 AM   #10
Gangplank
Colonel
Gangplank's Avatar
United_States
1197
Rep
2,587
Posts

Drives: 2011 e82 135i n55 Sprt DCT - S
Join Date: Nov 2015
Location: Port St. Lucie, FL

iTrader: (1)

Garage List
2011 135i  [0.00]
Quote:
Originally Posted by Ryder6foottoo View Post
Checked the code and it was for a lean bank 1 and multiple cylinder misfire.

I decided to take it to an unnamed shop.
They told me it was my ECU.

So I had it replaced. Problem was better. But not fixed.

So I took it back. They told me it was my index 09 injectors.

Okay then. Replaced with index 12.
Problem got worse.

They told me it was potentially a plug or wire issue.
Okay no problem I guess.

Replaced with Precision Moterwerks Coilpacks and new plugs.

Problem continued.

Took it back AGAIN for some reason.
THEY TOLD ME IT WAS MY ECU AGAIN.

For some reason I let them "recode my ECU"
First I would flash it back to stock, cleared codes and see if any come back. Then fix what needs it.

If you can pull & clear the codes, what codes do you have now? I would down load them so you have a copy, clear them out & see what codes come back.

Also why are you using non-BMW coils, possibly adding to a problem? Are the injectors & plugs BMW?

I'd take it to a good Indy shop and have the shop run diagnostics. Let them know whats that's been done and let them diagnose. I won't be surprised if they recommend new BMW coils, new BMW plugs, and update the ECU and modules + code injectors.
__________________
2011 135i DCT | Sport pkg | PPK | Ohlins R&T swift sprigns | M3 front arms | Diff. brace | RSFB inserts.
Appreciate 0
      01-07-2019, 02:46 PM   #11
akmandal
New Member
0
Rep
5
Posts

Drives: 2008 135i Msport
Join Date: Aug 2018
Location: Raleigh, NC

iTrader: (0)

Also, there is a shop in Wendell called Leistung Performance. They are really awesome about my 135i and Porsche Cayman. Talk to Jo Jo. Tell them Abir sent you
Appreciate 0
      01-18-2019, 07:58 AM   #12
Blu3RSX
Industrial Designer
Blu3RSX's Avatar
United_States
26
Rep
38
Posts

Drives: 2013 135i. It's blu3 ^_^
Join Date: Oct 2018
Location: Tallahassee, FL

iTrader: (0)

Send a message via AIM to Blu3RSX
this might sound pretty trivial, but with all the oil that can blow by into the intake, you might want to try cleaning the MAP and MAF sensors if you haven't already to see if that helps.
__________________
Cowl Delete
Injen Intake
BMS Stage 1
BMS Pedal Tuner
Appreciate 0
      01-18-2019, 09:27 AM   #13
rejo88
New Member
rejo88's Avatar
United_States
2
Rep
26
Posts

Drives: 135i
Join Date: Jan 2015
Location: Miami

iTrader: (1)

Something like that happened to me, my car is stock.
I changed:
Injectors, spark plugs, coils. Ended up being the HPFP along with the sensors (this was the 3rd time it has been changed).
Now it has other issues, such as pedal module sensor and has boost leak.


-Rejo-
Appreciate 0
      01-18-2019, 10:06 AM   #14
c1pher
Primo Generalissimo
United_States
1338
Rep
2,188
Posts

Drives: Porsche Macan Turbo
Join Date: Jun 2009
Location: DC area

iTrader: (0)

There's a mom and pop in North Raleigh but I think they aren't really experienced with modders.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:37 PM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST