BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      07-14-2017, 02:51 PM   #1
WP1
Private
WP1's Avatar
9
Rep
94
Posts

Drives: White BMW 135i Convertible
Join Date: Sep 2013
Location: College Park, MD

iTrader: (0)

Help ASAP (High/Low pressure fuel sensors)

Hi All,

So driving the car yesterday on my way to work, the car started shacking and lost power. Then got the message of Engine Malfunction, operating at reduce power output to.

So, I panic and had it towed to the dealer.
  1. Dealer it saying High Pressure rail sensor needs to be replace $400
  1. 2Also recommends changing the Low sensor at the same time $800
Why this cost double?

So, I changing the High Rail Sensor.

What is the like-hood of the Low sensor to go bad? Also the fuel injectors were replaced under warranty back in April this year. So that have to do with the sensor going bad?

Thanks,

Over the pass year I have spent closed to $4K
__________________
Used to own the eclipse (avatar pix).
Sold it and post it in memory
Appreciate 0
      07-14-2017, 03:59 PM   #2
Dackelone
European Editor
Dackelone's Avatar
Germany
8054
Rep
22,438
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

I think your dealer is raping you! The low pressure sensor costs right around $100 for the part. COD labor is probably less than four hours labor rate(~$120/hr).

Is your car a N54 or N55 ?

N54 HPFP have an extended warranty...
__________________
Appreciate 0
      07-17-2017, 12:04 PM   #3
WP1
Private
WP1's Avatar
9
Rep
94
Posts

Drives: White BMW 135i Convertible
Join Date: Sep 2013
Location: College Park, MD

iTrader: (0)

Dackelone, thank you for your help. My car is 2010 convertible N54/ E88

Here is what happened.

I approved for the High Pressure rail sensor to be changed (which I still think it should be cover under warranty).

So, the dealer changed the HP rail sensor, but the car was't preforming well. So, dealer changed the Fuel Pump and took out the HP rail sensor. Tested the car again and didn't preform well. Dealer put the new HP sensor again and car worked well.

So the dealer told me that I needed the HP Rail Sensor and Fuel Pump for the car to work. Only the Fuel Pump was under the extended warranty.

I talked to the manager and asked all those questions and he can only tell me that the sensors are not cover, so gave me $75 off. I still think is BS.

Does anyone knows why the High/Low Pressure Sensors are no cover under the extended warranty?

I want to write to BMW headquarter instead of calling, so I can provide details. Does anyone knows the correct e-mail?

Thanks,
Francisco
__________________
Used to own the eclipse (avatar pix).
Sold it and post it in memory
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:33 PM.




1addicts
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST