BMW 1 Series Coupe Forum / 1 Series Convertible Forum (1M / tii / 135i / 128i / Coupe / Cabrio / Hatchback) (BMW E82 E88 128i 130i 135i)
 





 

Post Reply
 
Thread Tools Search this Thread
      09-07-2018, 06:47 PM   #1
135BANDIT
Second Lieutenant
135BANDIT's Avatar
Australia
11
Rep
265
Posts

Drives: 135 BMT & X5 Msport
Join Date: Feb 2010
Location: Gold Coast

iTrader: (0)

Battery pricing

Hi All,

I am about to replace the battery in our 2010 135 , I know it needs coding etc , but i was amazed at the price differential from the below.
  1. Mline bmw - $756
  2. GC bmw - $650
  3. Wside Bmw $775
  4. exide dealer gold coast - $265

The exide product is an AGM and 88ah , it seems crazy cheap ?

Any advice or other comments welcomed

Its also due for the Airbag and battery link recall
Appreciate 0
      09-07-2018, 08:27 PM   #2
Ric in RVA
Bergspyder
Ric in RVA's Avatar
United_States
500
Rep
695
Posts

Drives: '11 BMW 128i Sport 6mt
Join Date: Oct 2015
Location: Richmond VA

iTrader: (0)

Go to Exide. Buy battery. Buy bluetooth adapter and Carly. Code car to battery. Takes 2 minutes.

Those prices are insane.
__________________
Ric in RVA

2011 128i 6 MT Sport, 10 Land Rover LR4, 02 Mini Cooper S (for sale!), 2011 528i N52, Sequoia, Excursion, a few motorcycles.
Appreciate 0
      09-07-2018, 08:42 PM   #3
JBT2
Private First Class
JBT2's Avatar
Australia
23
Rep
115
Posts

Drives: 2008 E82 135i
Join Date: Oct 2016
Location: Brisbane, Australia

iTrader: (0)

Wow! Those prices seem high.

Bought mine (genuine spare part Exide) for $298.70 with club discount from Westside BMW in Nov 2016.
I removed the old one and fitted the new. Took about 30 minutes.
Coded by RX Automotive - complimentary for being a regular customer.
Appreciate 0
      09-08-2018, 07:22 AM   #4
johnny135
New Member
Australia
3
Rep
15
Posts

Drives: 135i
Join Date: Aug 2015
Location: Sydney

iTrader: (0)

The Exide AGM is the go. Got my Exide SSAGM77 for about $300 delivered. Already had obd and otg cables for MHD, bought Carly and coded and registered myself (original battery was not an AGM)

Varta batts seem to be a lot more expensive if you want them, Exide does the job.
Appreciate 0
      09-11-2018, 06:26 PM   #5
ansch
Captain
Australia
25
Rep
641
Posts

Drives: SGM 135i
Join Date: Dec 2008
Location: Brisbane, Australia

iTrader: (1)

RACQ.

You get a discount if you're a member and they do the install and coding for you.
https://www.racq.com.au/cars-and-dri...battery-finder
$280 for our cars

+ 3 years warranty
Appreciate 0
      04-10-2019, 01:35 AM   #6
racer_x
Second Lieutenant
racer_x's Avatar
7
Rep
225
Posts

Drives: When He Has To
Join Date: Jan 2013
Location: Sydney

iTrader: (0)

Hi Guys,

I am just looking for the symptoms of a dying battery an E82 135i.

Every now and then it does not want to crank at all... This is especially true when the engine is hot. Or when it's cold early in the morning. I assume that's when high cranking amps are needed.

Once it cools down, I can get it started on 1st or 2nd try.

My car is an MY09, does not have iDrive, and I'm not seeing any errors on the dash display.

Is this the battery on its way out? Or is it the alternator?

Car has about 85,000 kms and I suspect this is the original battery!!

Thanks for your help.
Appreciate 0
      04-10-2019, 04:44 AM   #7
Brule
Colonel
Australia
381
Rep
2,438
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

Sounds more like high pressure fuel pump failing.
My 2007 battery lasted to 2014 there pretty good oem batteries.



Sympton of low battery

Battery symbol on dash
Rally slow cranking over
Not able to unlock doors with button on key
Just a ticking souns coming from alternator when trying to start
Appreciate 0
      04-10-2019, 04:48 AM   #8
Brule
Colonel
Australia
381
Rep
2,438
Posts

Drives: 2007 335i e92 6spd man
Join Date: Jul 2013
Location: Darwin

iTrader: (0)

If its not cranking at all then cranking later its not the battery.
Could be alternator but if its not firing straight up its got more issues then alternator.

Start by checking codes if possible.
Appreciate 0
      04-10-2019, 05:09 AM   #9
My1er135i
New Member
United_States
0
Rep
14
Posts

Drives: 11 E82, Deep sea Blue 6 speed
Join Date: Feb 2016
Location: San Jose, Ca

iTrader: (0)

Quote:
Originally Posted by 135BANDIT View Post
Hi All,

I am about to replace the battery in our 2010 135 , I know it needs coding etc , but i was amazed at the price differential from the below.
  1. Mline bmw - $756
  2. GC bmw - $650
  3. Wside Bmw $775
  4. exide dealer gold coast - $265

The exide product is an AGM and 88ah , it seems crazy cheap ?

Any advice or other comments welcomed

Its also due for the Airbag and battery link recall
Hey there I got mine replaced in Central California for about $475ish from Bmw dealership.
Appreciate 0
      04-10-2019, 05:11 AM   #10
racer_x
Second Lieutenant
racer_x's Avatar
7
Rep
225
Posts

Drives: When He Has To
Join Date: Jan 2013
Location: Sydney

iTrader: (0)

No battery symbol on dash and I don't have a code reader.

It was in for the battery cable recall 4 or 5 years ago now but it has been flawless since. Can it be something loose?

Can anyone recommend a good workshop in Sydney's East?
Appreciate 0
      04-10-2019, 08:05 PM   #11
vtl
Brigadier General
vtl's Avatar
Australia
1116
Rep
3,005
Posts

Drives: 2008 BMW 135i MT
Join Date: Apr 2015
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by racer_x View Post
Hi Guys,

I am just looking for the symptoms of a dying battery an E82 135i.

Every now and then it does not want to crank at all... This is especially true when the engine is hot. Or when it's cold early in the morning. I assume that's when high cranking amps are needed.

Once it cools down, I can get it started on 1st or 2nd try.

My car is an MY09, does not have iDrive, and I'm not seeing any errors on the dash display.

Is this the battery on its way out? Or is it the alternator?

Car has about 85,000 kms and I suspect this is the original battery!!

Thanks for your help.
Do you mean nothing happens at all when you press the starter button? Even a low battery will at least click the starter solenoid

Probably the starter motor, not an uncommon failure on these cars, usually the starter solenoid on it gets stuck and another attempt later and it fires up no problems. Does it crank strong when it does start?
__________________
Build Thread | MHD Custom Tune | Agency Power DPs | PE Mod Exhaust | 550i Clutch | Wagner FMIC | M3 LSD | Turbosmart Kompact DVs | M3 Control arms | M3 steering rack | KW Competition Coilovers | Dinan Camber Plates | E92 M3 Front Sway | UUC Trans mounts | Nolathane rear subframe bushings | Alcon 355mm BBK | Yokohama AD08R | Apex EC-7 | Schroth Harness | M3 Steering Wheel | LEDs | CIC + Combox retrofit
Appreciate 0
      04-10-2019, 08:13 PM   #12
racer_x
Second Lieutenant
racer_x's Avatar
7
Rep
225
Posts

Drives: When He Has To
Join Date: Jan 2013
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by vtl View Post
Do you mean nothing happens at all when you press the starter button? Even a low battery will at least click the starter solenoid

Probably the starter motor, not an uncommon failure on these cars, usually the starter solenoid on it gets stuck and another attempt later and it fires up no problems. Does it crank strong when it does start?
It's intermittent. Yes when it refuses to start I get zero cranking. When it does start, it fires from 1st or 2nd crank. And no battery warnings.

Interesting about starter solenoid getting stuck. Might explain the zero cranking issue.

Looking at service records, the car is on its original battery / starter motor.

Would any of this leave any codes behind?
Appreciate 0
      04-10-2019, 08:41 PM   #13
vtl
Brigadier General
vtl's Avatar
Australia
1116
Rep
3,005
Posts

Drives: 2008 BMW 135i MT
Join Date: Apr 2015
Location: Melbourne, Australia

iTrader: (0)

Wont be any codes, from your description definitely sounds like the starter motor. At the very least doesn't sound like a dead battery.
__________________
Build Thread | MHD Custom Tune | Agency Power DPs | PE Mod Exhaust | 550i Clutch | Wagner FMIC | M3 LSD | Turbosmart Kompact DVs | M3 Control arms | M3 steering rack | KW Competition Coilovers | Dinan Camber Plates | E92 M3 Front Sway | UUC Trans mounts | Nolathane rear subframe bushings | Alcon 355mm BBK | Yokohama AD08R | Apex EC-7 | Schroth Harness | M3 Steering Wheel | LEDs | CIC + Combox retrofit
Appreciate 0
      04-10-2019, 08:43 PM   #14
racer_x
Second Lieutenant
racer_x's Avatar
7
Rep
225
Posts

Drives: When He Has To
Join Date: Jan 2013
Location: Sydney

iTrader: (0)

Thanks @vtl. I'll book it in for a check next week and report back.
Appreciate 0
      04-14-2019, 06:48 AM   #15
DR-JEKL
Major General
Australia
707
Rep
6,085
Posts

Drives: Space Grey E92 335i 6MT
Join Date: Jul 2012
Location: Newcastle Ozstraylia

iTrader: (3)

flat battery experiences in my two occasions have always resulted in the cluster dropping out and nothing happening when i hit the start button
Appreciate 0
      04-15-2019, 12:39 AM   #16
racer_x
Second Lieutenant
racer_x's Avatar
7
Rep
225
Posts

Drives: When He Has To
Join Date: Jan 2013
Location: Sydney

iTrader: (0)

Turns out battery was on its way out. A new battery has been installed and we're all good to go again.

The auto lock / unlock feature has stopped working though, so need to go back and have that recoded.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:51 AM.




1addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST